四月 30

RouterOS用了這麼久(3年多了),感覺上算是蠻穩的

不過凡事總有個萬一,所以備份也是很重要的

以下的Script就是幫助我們達成RouterOS備份自動化,而且備份完後會自動e-mail到你指定的位置

#Script在RouterOS 5.15中測試通過
#Date:2010/12/19
#Script Name:MailBackupFile
#-----------------------------------------
#SMTP伺服器位置
:local SMTP "msa.hinet.net"

#寄件人
:local MailFrom "ROSBackup@minitw.com"

#收件人
:local MailTo "ModifyHere@minitw.com"

#寄出後是否刪除已存檔的Log(/file裡的檔案)
#0=保留 1=刪除

:local DeleteLogFile 1

:local BackupFileName
:set BackupFileName ([/system identity get name] . "_Backup-" . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
 /system backup save name=($BackupFileName);
 delay 10;

/tool e-mail set from=$MailFrom;
 /tool e-mail set address=[:resolve $SMTP];

/tool e-mail send to=$MailTo subject=([/system identity get name] . " -- RouterOS Backup " . [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]) file=[$BackupFileName];

:delay 10;

:if ($DeleteLogFile =1) do={
 /file rem [/file find name=($BackupFileName)];
 }

:log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date] . " (CHT:備份email寄出)");

#---
#---

5 Responses to “全自動備份 RouterOS,並以Email寄送備份檔”

  1. 小林 Says:

    這個腳本很有價值
    mark,一下

  2. RouterOS,自动备份并以Email到邮箱 | 始于linux架构商业路由-RouterOS中文站 Says:

    […] 转自http://www.minitw.com/archives/695 […]

  3. Fully automatic backup RouterOS, Email send backup file | Technical News Says:

    […] the computer tea bags Blog […]

  4. ros初学 Says:

    先谢谢博主,但这脚本可以自动备份了,但是就无法发送到邮件去,#SMTP伺服器位置
    :local SMTP “msa.hinet.net”

    #寄件人
    :local MailFrom “ROSBackup”

    #收件人
    :local MailTo “ModifyHere@minitw.com”这个位置可以详细点的吗,还有ROS里的EMAIL怎么设置的呢。

  5. jason Says:

    to ros初学:
    SMTP的位置可能會依你的ISP不同,而有所差異。

    “msa.hinet.net”是台灣中華電信ISP用戶所使用的SMTP位置。

    :local MailTo “ModifyHere@minitw.com” 就是你要把這封mail寄到那裡去,
    例如:你要寄到abc@gmail.com的話,就是改成
    :local MailTo “abc@gmail.com”

留下評論

限制時效已用盡。請重新載入驗證碼。