一月 17

網路喚醒(WOL)是一個可以透過網路傳送封包,來達成遠端開機的技術。
詳細可以參考維基百科–網路喚醒或是如何透過網際網路遙控電腦開機 (Software: WOL magic packet sender)

使用前,請確認電腦的BIOS有開啟此項功能。不然你試半天,電腦也是不會理你的。

把以下的Script存到ROS裡面(請參考讓RouterOS自動把Log檔email出去),並把MAC改成你想啟動電腦的網卡MAC位置。

#Script在RouterOS 4.15中測試通過
#Date:2011/01/17
#Script Name:BootPCwithWOL
#Script Description:使用Wake on Lan的方式遠端啟動PC

#網卡的MAC請依照下面的格式填入
:local MACADDR "00:11:22:33:44:55";

:foreach eth in=[/interface ethernet find] do={
  /tool wol interface=$eth  mac=$MACADDR
}

接下來執行就可以了。